资讯详情

资讯详情

创建dblink报错

文章目录环境症状问题原因解决方案环境系统平台Linux x86-64 Red Hat Enterprise Linux 8版本4.5.8症状hgdb安全版458创建dblink报错create extension dblink ERROR: syntax error at or near TYPE 时间: 0.006s问题原因将关键字 type 配置到flatten_keyword_list参数中关键字变为普通标识符。解决方案参数解释flatten_keyword_list可配置任意关键字到此列表中被配置的关键字会被当做普通的标识符识别当关键字被识别成普通字符时,有些需要关键字的语法也就不能被识别。session_restore_keyword_list可配置任意关键字到此列表中被配置的关键字与flatten_keyword_list冲突时冲突关键字不会退化成标识符。当前会话再恢复为关键字加到这个列表。方法一去除flatten_keyword_list中关键字vi postgresql.auto.conf flatten_keyword_listxxxx,copy,xxxx 修改为 flatten_keyword_listxxxx,xxxx psql -U sysdba select pg_reload_conf()方法二session_restore_keyword_list 中添加关键字vi postgresql.auto.conf flatten_keyword_listxxxx,copy,xxxx session_restore_keyword_listcopy psql -U sysdba select pg_reload_conf()
觉得有用,分享给同行:

为您的企业打造数字门面

稳重轻奢商务风格,端正雅致视觉,长效耐看不易过时。

立即咨询 →